PDA

View Full Version : 65 turn signal switch


Gitanesteel
06-20-2017, 03:02 PM
Coming home from Wenatchee a month ago the turn signal indicator light started getting erratic. Regular flashing, fast flashing and no flashing. Driving the car a couple of weeks ago I noticed there was no turn indicator light so at a stop sign (rural country road) I got out and checked the rear. No lights flashing there either.

Seems to me there's a loose connection or the switch is going bad. Is the switch located in the steering column or dash. Unfortunately, if in the column I've never removed a horn ring, steering wheel, etc. before and frankly don't have a lot of faith in myself or the tools to remove the wheel (not that I can't buy them).

Luva65wagon
06-20-2017, 11:14 PM
Scott,

It's not clear whether you meant neither left or right are working or just one side only. The switch to fail on both sides at once, though possible, would be a little rare. If both sides have started failing, and due to the fact it has been erratic with flashing speed as well, I'd replace the flasher first.

The flasher is up under the dash somewhere. Usually right behind the instrument cluster and may be still attached to a little bracket. You'll have to feel around behind the dash for it and pull on it to get it free. You can usually pull it down and see it up-close and personal while still connected to the harness, like this:

6400 6401

If that doesn't provide you with much joy, then the turn signal switch may be failing completely, like it's coming apart or something. It's not too hard to replace and I looked on YouTube and they have a video on an earlier Mustang which is near identical.

https://www.youtube.com/watch?v=y2r40dvULpc

Hope this helps.

Gitanesteel
06-21-2017, 06:06 AM
Thanks Roger. I'll start with the flasher. Wasn't completely whether the flasher controlled just the light at the dash or also to the tail light flashing as well. I'll feel around up underneath next weekend when I finally have a couple of days free.

Edit: I just crawled under the dash and located the flasher. That's a really painful proposition with my degenerative low back condition. The flasher was loose and not in it's bracket. Connections look good. I sat in the seat and turned the key and reached under to move the flasher a little and was met with sparks - duh, it's hot. I suspect I've shorted it now as it just clicks when I move the turn signal lever. I'll order a new one, seat it in the bracket and see what happens.

Luva65wagon
06-21-2017, 08:47 AM
Scott, yes it is hot! I see a lot of them just dangling in space, which isn't a good idea.

Hind-sight being 20/20 and all I guess any suggestion to mess with underdash items should have the requisite "disconnect the battery" warning. The power to the flasher, like most wiring in a Falcon, isn't fused and as such it might be a good idea to disconnect the battery ground while working on this. The connectors on the flasher, if individual as opposed to a single dual connector, should be fairly well insulated, but if not (or even so) there are some exposed parts at potential - and if held shorted too long will burn up the entire wiring harness. There should be a flasher holding bracket on the back of the cluster or on the column support, so make sure you get the flasher back into it.

The flasher is wired pre-turn signal switch, so any voltage going through it will be pulsating, if it is working correctly. That is providing the on/off to left and right inside and out. The mention of varying speeds of flash pointed to the flasher.

Falcons have that kooky single turn indicator inside, which I despise. You may have noticed I undo that "feature" on many of the Falcons I build. Even though it is one bulb for left and right turn signal, it is two circuits in one bulb. I divide these into individual circuits, but I'm now rambling... sorry.

Luva65wagon
06-21-2017, 08:51 AM
Oh, and flashers are very common at all auto stores. So no need to order online from a Falcon vendor. Just have them look up the right one.

Gitanesteel
06-21-2017, 09:50 AM
Problem solved. Ran to NAPA and picked up a $4.64 Taiwanese flasher and all is good. It's also neatly nestled in the bracket and secure.

BadBird
06-21-2017, 11:05 AM
Problem solved? Means working correctly now? Great news if that fixed it. Larry

Gitanesteel
06-21-2017, 11:18 AM
Problem solved? Means working correctly now? Great news if that fixed it. Larry

Yep, Larry. The signals are working now - checked both left and right. Fortunately for me it was an easy fix. Little mechanical expertise and even more little faith in myself.

Luva65wagon
06-21-2017, 08:52 PM
Yay! [thumb]