PDA

View Full Version : Hello FalconForum


djkrs2
02-22-2008, 07:10 PM
Hello Everyone.

I'm new to the forum. I own a '62 4-door. It's white, but dirty at the moment. I purchased the car from my dad. He got it from a lady he knew after the engine had quit. The body is in excellent condition and he had the motor rebuilt and the bumpers re-chromed. Unfortunately when they painted the car the guy must not have grounded something because I don't have any lights. I need to fix this and then work on the interior, which really isn't bad for a 46 year old car. I also let it sit a little too long and it doesn't want to start but I'm sure I can get it going again. Fix the lights and it'll be on the road.

I look forward to reading the forums and hopefully getting some useful information.

Dave

Luva65wagon
02-23-2008, 12:33 AM
Dave,

Welcome! Hope you can get your car on the road. Sounds like some simple things to get past. Hey, you know, if they pulled the grill out when they painted the car, they may have unscrewed the ground wires from directly behind the headlights. This would be a quick thing to check for.

Well, let us know if you can't find the problem and we'll put our best minds to it for you.

redfalken
02-23-2008, 10:30 AM
Welcome Dave! Electrical problems can be mysterious but it can also be a great way to get to know your wiring. Buy a manual from one of the Falcon parts dealers or eBay if you don't have one and just keep poking around with the multitester. I also find those circuit testers that look like an awl with wires and a lightbulb in the handle very helpful and inexpensive.

As Roger said, we're here to help so speak up if you can't track it down. I'm sure one of us has been through it before.

djkrs2
02-23-2008, 11:15 AM
Thanks guys for the advice. I'll check and make sure they grounded at the grill but would that keep ALL the lights from working. Actually, I had a very dim left rear taillight at one time. I'm pretty sure it's a grounding problem somewhere because my dad said they all worked when he took it to get painted..

Thanks again.

Dave