Rainier Falcons > The FalconForum  

Go Back   Rainier Falcons > The FalconForum > General Forums > Show Off Your Ride

Reply
 
Thread Tools Display Modes
  #556  
Old March 30th, 2017, 04:33 PM
ew1usnr's Avatar
ew1usnr ew1usnr is offline
Senior Forum User
 
Join Date: Dec 2012
Posts: 847
Volkswagen Fighter

Quote:
Originally Posted by dhbfaster View Post
That might be the retirement project some day Larry...
Hello, Don.

If Larry gets feisty, you can start bragging about the great gas mileage that you are getting.

This is a picture of Don ==>
__________________
Dennis Pierson
Tampa, FL
"The Wonder Falcon"

'63 Futura Hardtop (260, Ford-O-Matic, bench seat)
Reply With Quote
  #557  
Old March 30th, 2017, 07:07 PM
BadBird's Avatar
BadBird BadBird is offline
Senior Forum User
 
Join Date: Dec 2006
Location: Mill Creek
Posts: 1,077
Saving Granddad's Falcon

There are no feisty bones in my pudgy little body. I just happen to have a right foot that is made out of lead. I posted what my gas mileage was on this forum somewhere but can't find it. It was over 20 MPG I do remember that. Which isn't too bad for dual carbs and a mild racing cam.
When I had the C4 transmission it was no where near that good, but with the T5Z it works out great.
When you grow up like I did, drag racing every Friday and Saturday night I guess you revert back to that when you get old like me.
Everyone has their own desires in rebuilding one of these beautiful cars. For me, it will probably always be in the form of a hot rod.
Which reminds me. I have a new tee shirt ordered that says "Some grandfathers play bingo, I drive hot rods". Larry
__________________
Larry Smith
1964 Futura
347 stroker


Reply With Quote
  #558  
Old April 22nd, 2017, 07:01 AM
dhbfaster dhbfaster is offline
Senior Forum User
 
Join Date: Jul 2013
Location: Federal Way
Posts: 813
So, I think I've got holes where these light switches in the pic go.
I'm assuming mine, being a basic model, never had them...a bit torn as to whether or not to put some in. (One more mod away from the original interior). Are they easy to hook up?
Attached Images
File Type: jpg IMG_0160.jpg (91.7 KB, 8 views)
__________________
Don Bartlett
Federal Way, WA
61 Four Door Sedan
144-6, 3 on the tree


Reply With Quote
  #559  
Old April 22nd, 2017, 10:50 AM
Luva65wagon's Avatar
Luva65wagon Luva65wagon is offline
Chapter President
 
Join Date: Oct 2006
Location: Seattle
Posts: 4,443
Yes and no. They feed a dome light, and if you didn't put one in, that could be hard once the headliner is in. You could feed some floor courtesy lights instead, like those on early mustangs and a certain Ranchero I know of.

You'll need a harness too, which I have an extra one of. You probably have the connectors in the dash harness for that already.

WIAI!
__________________
Roger Moore

63 "Flarechero"
powered by: '65 289-V8 | T5 | 8" TracLoc rear


Reply With Quote
  #560  
Old April 22nd, 2017, 12:04 PM
dhbfaster dhbfaster is offline
Senior Forum User
 
Join Date: Jul 2013
Location: Federal Way
Posts: 813
There is a dome light there, but it only turns on/off manually by rotation of the headlight knob.
__________________
Don Bartlett
Federal Way, WA
61 Four Door Sedan
144-6, 3 on the tree


Reply With Quote
  #561  
Old April 22nd, 2017, 09:41 PM
Luva65wagon's Avatar
Luva65wagon Luva65wagon is offline
Chapter President
 
Join Date: Oct 2006
Location: Seattle
Posts: 4,443
Oh, that's good. There is a two-wire T'd harness that plugs into where that dome light wire is going and the switches you add get 12v constant on one side (supplied by the harness) and the other side to the dome light connection you have now. So you put 12v to the dome light either by the headlight switch or the door switch. Pretty simple install with the harness.
__________________
Roger Moore

63 "Flarechero"
powered by: '65 289-V8 | T5 | 8" TracLoc rear


Reply With Quote
  #562  
Old April 23rd, 2017, 05:02 PM
dhbfaster dhbfaster is offline
Senior Forum User
 
Join Date: Jul 2013
Location: Federal Way
Posts: 813
Sounds pretty simple. Anyone you know of sell that harness?
__________________
Don Bartlett
Federal Way, WA
61 Four Door Sedan
144-6, 3 on the tree


Reply With Quote
  #563  
Old April 24th, 2017, 12:09 AM
Luva65wagon's Avatar
Luva65wagon Luva65wagon is offline
Chapter President
 
Join Date: Oct 2006
Location: Seattle
Posts: 4,443
I have one or two. You can have one.
__________________
Roger Moore

63 "Flarechero"
powered by: '65 289-V8 | T5 | 8" TracLoc rear


Reply With Quote
  #564  
Old April 30th, 2017, 06:35 PM
dhbfaster dhbfaster is offline
Senior Forum User
 
Join Date: Jul 2013
Location: Federal Way
Posts: 813
Appreciate the offer Roger- I might take you up that if I can get by in June.

I drove the falcon to work Friday afternoon and put about 25 miles on it between there, going to the chiropractor, and driving around before I went home. The engine run absolutely perfect and tranny and clutch seemed perfect as well. I've got to get the right tires. Everyone commented about them....just can't see buying rubber that is going to rot in my garage yet.

Funny thing- Gene, remember that the front ball joints didn't seem like they didn't have enough grease in them? I couldn't seem to get more in with my small hand gun at home so I stopped into Jiffy Lube on the way home to have them try it using a professional gun with more pressure. Guess what- they were out of grease! What kind of place with "lube" in the name runs out of grease? I thought that was pretty funny.

There's some kind of popping sound when I do a hard turn like out of the driveway or into a parking spot. It seems to be coming from the passenger side front suspension. I was wondering if it's just due to the ball joints not having enough grease (so I thought I'd try that first- but didn't get a chance to.) I suspect it might have something to do with the lower control arm having that twist in it that Larry and Gene helped bang back into shape. I stuck my head under and took a peek, and it seems to not be as straight as when we installed it back on the car. Anyway, that's for next trip to find out. Anyone have any ideas...please post!

I also have some kind of light so "clang, clang" sound coming from the trunk area. Haven't figured that out yet, but I don't think it's the diffy. I heard it once when I closed the trunk, then played with the trunk lid springs a bit and it didn't happen when I closed the trunk after- but I haven't had a chance to drive it again since then.

I also heard the drivers side spring mount knock...Roger, not sure if you remember the front mount for the leaf springs that's bent? So the mounting bolt with the big cup washer does not fit into the cup (the bolt was bent before- I straightened it but maybe shouldn't have. I'll need to figure out how to address that one way or another at some point.

I decided my "take back to Canada" project is the steering wheel. It's in my suit case along with everything else I think I'll need except the paint. I have a free weekend coming up. I hope I can get the paint delivered in time.

Speaking of my flight back to Canada today....it was supposed to be a direct flight. The pilot got on and said the smoke alarm went off for the baggage compartment and the fire suppression system went off and they had to make an emergency landing in Spokane! They were very professional, but I thought there was a small chance that I should have updated my will and make sure the falcon was going to Jason, and then if Jason didn't want it, done it to Roger to use for the benefit of the club in whatever way he see's fit...but about 7 minutes later we were on the ground. They stopped the plane immediately and sent the emergency crew out. No fire, and apparently the fire suppression system didn't go off. Four hours later and I'm sure a lot of paperwork they sent a plane from Vancouver and I'm on my flight to Toronto now.

I decide to push the radio project down the road a bit and focus on the steering wheel. I emailed Joe's radio restoration about the tuner and he said there is a clutch in the tuner inside that when you push a tuning preset button disengages so that the button can move the tuner to the channel it's set to. He said they have to take it apart and replace the "clutch" which is basically a plastic rubber like disc that over time gets too hard and slippery. Anyway, I was going to try and figure out the capacitors to order and have them delivered the house for when I am back in June. Planning a two week visit late June and early July including some "staycation." Hopefully I can bring the radio over Roger and check the tubes.

I'll post some pics on the steering wheel project when I get it going.
__________________
Don Bartlett
Federal Way, WA
61 Four Door Sedan
144-6, 3 on the tree



Last edited by dhbfaster; April 30th, 2017 at 06:40 PM.
Reply With Quote
  #565  
Old May 1st, 2017, 11:04 PM
Luva65wagon's Avatar
Luva65wagon Luva65wagon is offline
Chapter President
 
Join Date: Oct 2006
Location: Seattle
Posts: 4,443
Quote:
Originally Posted by dhbfaster View Post
Appreciate the offer Roger- I might take you up that if I can get by in June.
It may just be in your mailbox when you get home...
2017-05-01 09.43.45.jpg

Quote:
Originally Posted by dhbfaster View Post
There's some kind of popping sound when I do a hard turn like out of the driveway or into a parking spot.
Dry joints would be my first guess as well

Quote:
Originally Posted by dhbfaster View Post
I also have some kind of light so "clang, clang" sound coming from the trunk area. Haven't figured that out yet, but I don't think it's the diffy. I heard it once when I closed the trunk, then played with the trunk lid springs a bit and it didn't happen when I closed the trunk after- but I haven't had a chance to drive it again since then.
Trunk torsion springs should have one of them wrapped with a coil of rubber or Teflon or something to keep one from rubbing and clanging against the other. Not the best picture, but you can see...

springwrap.jpg

Quote:
Originally Posted by dhbfaster View Post
I also heard the drivers side spring mount knock...Roger, not sure if you remember the front mount for the leaf springs that's bent?
Vaguely recall maybe reading of it. If I looked at it in person, that I don't recall.

Quote:
Originally Posted by dhbfaster View Post
Hopefully I can bring the radio over Roger and check the tubes.
I'll make sure my tube tester book lists these specific tubes. If not, then you may just want to buy some of them new to be sure.
__________________
Roger Moore

63 "Flarechero"
powered by: '65 289-V8 | T5 | 8" TracLoc rear


Reply With Quote
  #566  
Old May 21st, 2017, 10:49 AM
dhbfaster dhbfaster is offline
Senior Forum User
 
Join Date: Jul 2013
Location: Federal Way
Posts: 813
I've been working on the steering wheel a bit.
Got the 20 or so cracks all opened up and turned into grooves the pc7 epoxy can go into.
Huge mess! I was only in trouble for about a day though. Let's just say I miss not having a garage to do this stuff in.

Meanwhile, I have filled them all with the epoxy and that has cured. It's quite solid. Yesterday I began shaping it all back down so it looks like a steering wheel again. (While I was outside...) still very messy and requires LOTS of patience. hopefully not more patience than I have!

Ordered the paint from Eastwood 2.5 weeks ago and it's still not here! I'll post a few more pics after I finish all the sanding and shaping. Raining here today...not sure if I will get to work on it or not. I suspect it could be a couple weeks before I'm ready to paint.
Attached Images
File Type: jpg IMG_0184.jpg (180.4 KB, 10 views)
__________________
Don Bartlett
Federal Way, WA
61 Four Door Sedan
144-6, 3 on the tree


Reply With Quote
  #567  
Old June 27th, 2017, 10:45 PM
dhbfaster dhbfaster is offline
Senior Forum User
 
Join Date: Jul 2013
Location: Federal Way
Posts: 813
I didn't get the steering wheel done but I brought it back so I can drive the falcon this week. It seems at the rate I'm going I'll be lucky to have it ready for next season. BUT, Here for the long weekend on a "staycation."
I put 5o or so miles on the falcon last weekend and the odometer just rolled over 100 miles today. WoW! I still can't believe it's all working so well (knock on wood.) Drove it to work Monday just like it was my regular car except I was having more fun. Sunday I drove over to Ruston and back. What a beautiful drive. Mt Rainier was out and everything. Man I miss it here. Over there in Ontario what they call "the mountain" is about 200 feet high and the lakes are just gray and boring compared to Puget Sound. Anyway, I ended up on I-5 and got up to 70mph for a bit and it ran great. It was quite warm out- and the wind beating on you through the windows felt just like it used to. The vents down below work amazingly well just like always. Unfortunately I was then down to I-5 stop and go traffic. I did watch the temp gage (picture) go up a bit...normally it has been right in the center or inside the right side of the circle. In the stop and go traffic it got a bit outside of the circle. Fortunately, things picked up a bit and everything was fine...but my question:

What is the point on this gage that I should get worried??
Am I ok all the way to the dot?

I heard the suspension noise again tonight...and found it seemed to be only when I bumped a speed bump. I think I found it- It turned out I left the steering loose where it bolts to the frame...that is rectified now. I'll test drive it to work again tomorrow. Got my new classic plates and the club plate on tonight too. I'll have to get some pics of that this weekend.

Also notice the falcon looks really great at night. I wasn't able to get the dash or interior lights to come on though. I'll have to play with that tomorrow night.
Hope all of you are enjoying the show season.
Attached Images
File Type: jpg IMG_3214.jpg (136.3 KB, 7 views)
File Type: jpg IMG_3215.jpg (86.3 KB, 8 views)
__________________
Don Bartlett
Federal Way, WA
61 Four Door Sedan
144-6, 3 on the tree


Reply With Quote
  #568  
Old June 28th, 2017, 11:17 AM
BadBird's Avatar
BadBird BadBird is offline
Senior Forum User
 
Join Date: Dec 2006
Location: Mill Creek
Posts: 1,077
Saving Granddad's Falcon

Don, I don't have that type temp gauge working on my car. My after market gauge gives numerical listings. I used to panic when mine would get to 220 but was told that not to worry unless it boils over.
Do you know what temp thermostat you have in the car? I would assume that if it gets to the dot, that would be 220?? Heck if I know, my response sounds like a dolts answer, but after hearing the guy at the Maltby show so upset that no one answered his query??? Just have to chime in. Now you know a lot more than you did. Kidding.
Glad you are getting to drive the car now. Hope it gets to a show soon. Larry
__________________
Larry Smith
1964 Futura
347 stroker


Reply With Quote
  #569  
Old June 28th, 2017, 04:14 PM
ew1usnr's Avatar
ew1usnr ew1usnr is offline
Senior Forum User
 
Join Date: Dec 2012
Posts: 847
Relax

Quote:
Originally Posted by dhbfaster View Post
What is the point on this gage that I should get worried?? Am I OK all the way to the dot?
Yes. You are OK. Do not worry about it unless the needle swings all the way to the right and stays there.
(But if a radiator hose breaks and dumps the coolant your engine will overheat without the gauge swinging to the right).

This is a temperature gauge for a 1963 Falcon. Notice the two larger outside marks and the two smaller inside marks.

Falcon temperature guage.jpg

The Falcon owner's manual says that the normal temperature range is in between the small marks;

Temperature Guage.JPG

The midpoint on the gauge seems to be about 190 degrees. The boiling point for a 50/50 antifreeze mix with a 13 psi radiator cap is about 257 degrees and that is probably approximately where the gauge pegs to the right.

Antifreeze-PeakChart.jpg

I have read that "A quality conventional motor oil will tolerate oil sump temperatures of up to 250 degrees, but starts breaking down over 275 degrees."

So, it is like Larry said, if you are not boiling over then you are OK.
__________________
Dennis Pierson
Tampa, FL
"The Wonder Falcon"

'63 Futura Hardtop (260, Ford-O-Matic, bench seat)

Last edited by ew1usnr; June 28th, 2017 at 04:23 PM.
Reply With Quote
  #570  
Old June 28th, 2017, 11:16 PM
Luva65wagon's Avatar
Luva65wagon Luva65wagon is offline
Chapter President
 
Join Date: Oct 2006
Location: Seattle
Posts: 4,443
Fresh motors also produce more heat and less after they've broken in. I freak out when the temp gets near 200 on my Autometer gauge, but it is true that it is only when it boils over that it is too hot. But isn't that too late?



I have seen such a variety of temps from gauge to gauge on the same car/engine (other 'experimenting' I've done), so it's almost better the factory "safe range" as opposed to a number... that may or may not be accurate.

So, Don, should I mail you that dome light wire? Will you be there to get it? It would be easy to add while you're under there trying to figure out what's up with the dash and dome light, which sounds like a fuse on the headlight switch to me.
__________________
Roger Moore

63 "Flarechero"
powered by: '65 289-V8 | T5 | 8" TracLoc rear


Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:20 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.