Rainier Falcons > The FalconForum  

Go Back   Rainier Falcons > The FalconForum > General Forums > Chit Chat

Reply
 
Thread Tools Display Modes
  #1  
Old 09-06-2014, 12:27 PM
doghows's Avatar
doghows doghows is offline
Senior Forum User
 
Join Date: Aug 2009
Location: Sequim
Posts: 2,111
Mini regional & me

Well looks like the delivery may not make the show. After the last trip to Seattle on my way home I was having a hard time keeping her n the road. I thought I was just tired. I drove her to work the following week and what the F*** she was every where.
So I get her home dove under the front end and my drivers side strut bar had come loose. I thought ok no problem. I torqued it backup looked for any other issues and went for my test drive. Same thing. So my only hope right now is to see if our one only good alignment shop can squeeze me in and see if it's just knocked out of alignment.
Bad news is our one good shop is usually three weeks out on appointments?cross your fingers cause if she needs parts she's staying home.
__________________
63 Sedan Delivery
5.0 HO EFI AOD 8" rear
Reply With Quote
  #2  
Old 09-06-2014, 03:12 PM
pbrown's Avatar
pbrown pbrown is offline
Administrator
 
Join Date: Sep 2006
Location: Seattle
Posts: 1,322
Blog Entries: 21
Check the lower control arm and make sure it didn't get bent. There is a lot of force held back by the strut rod, especially when braking. Did it come loose at the front or rear? I'm assuming at the front.

Good luck and I hope to see you at the show. Let me know if you need parts. I think I still have my old original strut rods and bushings.
__________________
Patrick Brown
331 Stroker / T5 / 8" / Wilwood Disks / RRS R&P Steering / Megasquirt EFI


Last edited by pbrown; 09-06-2014 at 04:13 PM.
Reply With Quote
  #3  
Old 09-06-2014, 04:05 PM
doghows's Avatar
doghows doghows is offline
Senior Forum User
 
Join Date: Aug 2009
Location: Sequim
Posts: 2,111
It came loose at the front. The rod is fine I'll take a closer look at the control arm and compare it to the pass side. Fingers crossed.
__________________
63 Sedan Delivery
5.0 HO EFI AOD 8" rear
Reply With Quote
  #4  
Old 09-06-2014, 05:40 PM
redfalken's Avatar
redfalken redfalken is offline
Administrator
 
Join Date: Sep 2006
Location: Seattle
Posts: 1,612
Blog Entries: 5
I hope you can get an appointment or figure it out on your own! That's a bummer. By "same thing", did you mean it came loose again after you torqued it down or just that it's still not driving right?
__________________

Kenny Likins
Ballard, Seattle, WA
www.redfalken.com

`62 Tudor Sedan (`69 200, C4, 8-inch 4-lug 2.79 rearend, Duraspark II, MSD, Weber 32/36 DGEV)
Reply With Quote
  #5  
Old 09-06-2014, 06:15 PM
doghows's Avatar
doghows doghows is offline
Senior Forum User
 
Join Date: Aug 2009
Location: Sequim
Posts: 2,111
Still not driving right. I'm fairly confident it's just way out of alignment. I went out and looked real good at both lower control arms and I cannot see any difference between them. Held a straight edge up to them and they both looked the same. I'll have to pull out my " you like powder coating right " card!!
__________________
63 Sedan Delivery
5.0 HO EFI AOD 8" rear
Reply With Quote
  #6  
Old 09-06-2014, 07:17 PM
Nathan289's Avatar
Nathan289 Nathan289 is offline
Moderator
 
Join Date: Oct 2006
Location: Deer Park
Posts: 1,100
Blog Entries: 1
Are the threads stripped? What caused the adjustment nut to all of a sudden get loose?

My guess is the alignment shop adjusted caster by cranking the heck out of the strut rod, putting way too much stress on it. Driving it caused the threads to pop...

I've seen a lot of shops adjust caster this way.. its not the proper way to add 1.5* of caster. Its for fine tuning. 3/4 of a degree max..


Inspect your strut rod closely.
__________________
Nathan and Jen Cooper
63 Sprint Hardtop "Dollora"
63 Super deluxe squire wagon "Mayble"
* this spot is vacant for future project*
Reply With Quote
  #7  
Old 09-06-2014, 07:32 PM
doghows's Avatar
doghows doghows is offline
Senior Forum User
 
Join Date: Aug 2009
Location: Sequim
Posts: 2,111
That's not a bad idea. It tightened back down easily so hopefully it's ok. I'll be out in the shop first light and checking her over. Thanks.
__________________
63 Sedan Delivery
5.0 HO EFI AOD 8" rear
Reply With Quote
  #8  
Old 09-07-2014, 03:22 PM
doghows's Avatar
doghows doghows is offline
Senior Forum User
 
Join Date: Aug 2009
Location: Sequim
Posts: 2,111
Dug deep onto the delivery today, wheels off, checked wheel bearings, check brakes, got a good look at all the suspension pieces and it all looks Ok. So let us hope it is just an alignment issue
__________________
63 Sedan Delivery
5.0 HO EFI AOD 8" rear
Reply With Quote
  #9  
Old 09-08-2014, 11:15 AM
Luva65wagon's Avatar
Luva65wagon Luva65wagon is offline
Chapter President
 
Join Date: Oct 2006
Location: Lynnwood
Posts: 4,406
Blog Entries: 4
You can check simple things like toe-in with a tape measure. Maybe one of the adjusters spun. Make sure they are tight too. Also, make sure the upper control arm nuts are tight too. My alignment guys didn't torque these as they should have on my first Ranchero alignment. They we snug, but not torqued.

Hoping it gets resolved!! It would be a significant bummer to not see it there.
__________________
Roger Moore

63 "Flarechero"
powered by: '65 289-V8 | T5 | 8" TracLoc rear


Reply With Quote
  #10  
Old 09-08-2014, 01:22 PM
doghows's Avatar
doghows doghows is offline
Senior Forum User
 
Join Date: Aug 2009
Location: Sequim
Posts: 2,111
Well just got done begging and pleading to no avail. Alignment shop is booked out three weeks. My appointment is September 29th. Best he could do was put me on the will call list.
So seeing how I do not trust the two other shops we have I guess I need to decide if it's worth ruining a few hundred dollars worth of tires, and possible crash or just be a worker bee?
Hmmm now I wish I hadn't sold my truck and trailer so soon. Oh well we will see I'll be there one way or another.
Speaking of which my good friend Ron wants to drive over in his 65 galaxie. I told him it was probably ok but he'd have to park in the corner. Let me know if this is a problem or not. Thanks Steve.
__________________
63 Sedan Delivery
5.0 HO EFI AOD 8" rear
Reply With Quote
  #11  
Old 09-08-2014, 01:55 PM
Luva65wagon's Avatar
Luva65wagon Luva65wagon is offline
Chapter President
 
Join Date: Oct 2006
Location: Lynnwood
Posts: 4,406
Blog Entries: 4
Tell him to come. There'll be plenty of space I'm told.

As for your car, on your garage floor (that's pretty level and flat) if you pull it in as straight as you can so you see anything about the wheels and tires that would say excess camber? This could only change if the upper control arm shims, or a ball-joint, changed. Caster is hard to see being off visually. Toe-in can be measured (sort of) with a tape measure across the back of the tires compared to the front of the tires. Excess toe-in or too little would only change if the tie-rod-end adjusting sleeves came loose on both ends of the adjuster - or a tie-rod failed.

Because you now have a rack in here you might want to verify the shaft to the steering wheel is all still tight and that sitting (engine off) there isn't excessive play in this new rack.

Sad you only have one shop worth anything there in town, but you'd think even a Les Schwab has means to scope out what might be wrong.
__________________
Roger Moore

63 "Flarechero"
powered by: '65 289-V8 | T5 | 8" TracLoc rear


Reply With Quote
  #12  
Old 09-08-2014, 04:54 PM
Jeff W's Avatar
Jeff W Jeff W is offline
Super Moderator
 
Join Date: Oct 2006
Location: Seattle
Posts: 1,326
Blog Entries: 3
On the bright side with your car out of the picture, if Roger doesn't bring his wagon, I may have the best two door wagon there

How about Port Angeles? Any decent shops there? As Roger said, significant bummer...
__________________

Jeff Watson
Seattle, WA
'63 Tudor Wagon (170 - 3 spd.)
Reply With Quote
  #13  
Old 09-08-2014, 04:55 PM
doghows's Avatar
doghows doghows is offline
Senior Forum User
 
Join Date: Aug 2009
Location: Sequim
Posts: 2,111
Yup most people won't touch Schwabb or discount over here. But all their employees are like 12 I think.
My alignment guy gave me some good tips and I'll check those tonight and drive her. If it turns out not to bad I'm going for it.


My guy is in port Angeles. He's the best on this side of the bridge!!
__________________
63 Sedan Delivery
5.0 HO EFI AOD 8" rear
Reply With Quote
  #14  
Old 09-08-2014, 08:05 PM
doghows's Avatar
doghows doghows is offline
Senior Forum User
 
Join Date: Aug 2009
Location: Sequim
Posts: 2,111
Update

Ok toe in is good, tires look straight from front view. So probably just a caster issue. My alignment guy said that caster is not a high wear on the tires issue. Everything looks tight, and we feel that a 200 mile road trip should not wear the tires too bad. If it was a toe issue he said do not drive it.
Took her for a spin today and things seemed a bit better after checking everything I was told to so I think I'll drive it to work on Wednesday and if she behaves were going for it!!
Waited to long and worked to hard to miss our first Falcon meet.
__________________
63 Sedan Delivery
5.0 HO EFI AOD 8" rear
Reply With Quote
  #15  
Old 09-09-2014, 02:57 PM
Jeff W's Avatar
Jeff W Jeff W is offline
Super Moderator
 
Join Date: Oct 2006
Location: Seattle
Posts: 1,326
Blog Entries: 3
Better throw a couple hundred pounds in the back for your test drive. You don't want any surprises come Sunday morning when you are loaded up for real.
__________________

Jeff Watson
Seattle, WA
'63 Tudor Wagon (170 - 3 spd.)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Mini Regional Luva65wagon Events and Announcements 180 09-19-2014 08:34 PM
Mini-Regional Promotional Ideas redfalken Events and Announcements 3 06-03-2014 08:03 PM
Mini Regional 2014 BPVan Events and Announcements 1 11-27-2013 10:02 PM
Falcon Mini Regional pics Gina K Events and Announcements 26 08-29-2013 02:49 PM
mini regional falcon meet Nathan289 Events and Announcements 74 09-24-2012 10:09 AM


All times are GMT -7. The time now is 10:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.